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Uploading from an Existing Controller for the First Time

The term Discover in Connected Components Workbench software is used for uploading from an existing controller for the first time.

1. Open Connected Components Workbench software (under All Programs/Rockwell Automation/CCW).

2. Click Discover… on the Start Page.

3. Find and click the desired Micro800® controller in the Connection Browser (RSWho) window, then click OK. Connect 
your PC to a Micro810® controller using a USB cable and a 2080-USBADAPTER; to a Micro820® controller via Ethernet; to a 
Micro830® controller via USB; and to a Micro850® or Micro870™ controller with either USB or Ethernet.
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4. The controller image will be uploaded into a new project, including any plug-in and expansion I/O modules physically 
found connected to the controller. If the project in the controller does not have all of those physical modules that are 
configured within the image, then you will get the following error message: “The current project content does not match 
the content in the connected controller. The software will not automatically go online (‘Connect’) with the controller.”  
In this case, the best thing to do is to follow up with an Upload from the controller, which will sync up the offline image 
with the online image. The software will then automatically go online (‘Connect’) with the controller.

5. You can save the offline project under a name of your choosing by selecting File->Save Project As…

If you get a Connection Error popup window or if the upload fails because “The imported database 
version is more recent than the product database version.”, then most likely the controller was 
programmed with a newer version of Connected Components Workbench software. Update your 
Connected Components Workbench software to the latest version before trying again.
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Opening an Existing Offline Project

A Connected Components Workbench software project consists of a ProjectName folder containing a number of subdirectory 
folders and files. They must all be present to open the ProjectName.ccwsln file.

1. Open Connected Components Workbench software (under All Programs/Rockwell Automation/CCW).

2. Click Open Existing… on the Start Page.

3. Browse to and double-click the desired controller project folder, then double-click the CCWSLN file within that folder to 
open the project.
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Opening a Saved Offline Project

A Connected Components Workbench software CCWARC archive file is equivalent to a Logix ACD file in that the one file contains 
everything that you need to open up the Connected Components Workbench software project. However, you must import it first.

1. Open Connected Components Workbench software (under All Programs/Rockwell Automation/CCW).

2. Select File->Import Project… and browse to and double-click the desired *.ccwarc file to import and open the project.

TIP: It is recommended to use the single CCWARC archive 
file for copying and sharing projects, instead of copying the 
entire folder that contains the CCWSLN file.
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Downloading an Offline Project to a Controller

1. With the offline project open and the Micro800 controller window displayed, check if there is a connection (‘project’) path 
displayed for the controller on the upper right-hand corner of the screen. If so, when you click Download, it will use that 
path to attempt to connect with the controller. If the path is no longer valid, click the eraser icon to delete it. Once the 
path is deleted, or if no path is displayed to begin with, click Download and the Connection Browser (RSWho) window 
will open for selecting the controller to download. The path will be updated automatically once you select the controller.

2. There are two options presented for downloading – with Project Values or without Project Values. Project Values are 
a snapshot of the values of each tag (‘variable’) when the project was last uploaded (assuming the upload used was 
‘Discover’ or ‘Upload with Project Values’). Any tag (‘variable’) may also be assigned an initial value, in which case the 
initial value is always used after a download. Any tag (‘variable’) that doesn’t have an initial value is set to zero when 
Download (without Project Values) is selected. Unless you actually want to zero out every non-initialized tag (‘variable’), 
click Download with Project Values.

3. When the download is completed, a window to change the controller to run mode pops up (whether the controller was 
previously in run mode or not). Click Yes or No. The software will automatically go online with the controller at this point.

TIP: To preserve a tag value in the controller 
from being overwritten or zeroed during 
download, use the download Data Protection 
feature accessible by right-clicking on the 
controller in the project organizer.  Data 
Protection has precedence over Initial Value 
and Project Value.

TIP: During download, Data Protection has 
precedence over Initial Value, which then has 
precedence over Project Value.

TIP: Downloading with Project Values is 
equivalent to the Studio 5000® behavior for 
downloading tag values, but it does take 
longer than without Project Values since 
almost all tags values must be downloaded.  
Using Initial Values on select tags and 
downloading without Project Values will 
decrease download time.
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Going Online with a Controller

The Connected Components Workbench software term for going online with a controller is Connect.

1. With the offline project open, check if there is a project (‘connection’) path displayed for the controller. If so, when you 
click Connect, it will use that path to attempt to connect with the controller. If the path is no longer valid, click the eraser 
icon to delete it. Once the path is deleted, or if no path is displayed to begin with, click Connect and the Connection 
Browser (RSWho) window will open for selecting the controller to go online with. The path will be updated automatically.

2. If there are any differences between the offline project and the online project, the Download/Upload confirmation 
window will appear. Choose between downloading the current offline project to the controller or uploading the online 
project and saving it as the offline project.

3. When you are online (‘Connected’) with the controller, note where the Connected text is displayed and where the button 
to Disconnect (i.e., to go back offline) is.
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Password Protecting Future Controller Access

Once online (“Connected”), the controller can be password protected, if desired. This prevents unauthorized users from accessing 
the configuration and programming in the Micro800 controller unless they first enter the password, which consists of 8 to 32 
characters in length. Valid characters are uppercase and lowercase letters, numbers, spaces, and symbols found on the keyboard. 
This password does not protect the offline file from edits or viewing. For this, you must separately apply passwords to individual 
programs and/or UDFBs.

1. While online with the controller, click Secure and select Set Password.

2. Enter Password, reenter the password in Confirmation and click OK.



12. BACK

Online Monitoring of Programs and Tags

The Connected Components Workbench software term for Online is Connected.

1. Once online with the controller, double-click the program name icon under Project Organizer of the program that you 
want to monitor. Blue is the rung color that is used to indicate that the rung logic is false and red is the rung color that is 
used to indicate that the rung logic is true.

2. To monitor the tag values in list format, double-click any tag name to bring up the Variable Monitoring window. Program 
tags are listed under the Local Variables tab and user-created controller tags are listed under the User Global Variables 
tab.
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3. To open a separate screen of all local program tags, double-click the Local Variables icon under the program name in the 
Project Organizer.

4. To open a separate screen of all global controller tags, double-click the Global Variables icon under the program name 
in the Project Organizer.
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Forcing I/O

The Connected Components Workbench software term for Force is Lock.

1. While monitoring the I/O tags under Global Variables, click the Lock checkbox for each I/O tag that you want to force 
on or off. For outputs, check the Physical Value checkbox to force the output on and uncheck the Physical Value 
checkbox to force the output off. The output LEDs for forced outputs on the Micro800 controller will correspond to 
the forced value. For inputs, check the Logical Value checkbox to force the input on and uncheck the Logical Value 
checkbox to force the input off. The input LEDs for forced inputs on the Micro800 controller will correspond to the actual 
input value, not the forced value.

The FORCE LED on the Micro800 is on whenever there is at least on I/O point being forced. All forces are cleared after 
power cycle.
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Making Online Edits

The Connected Components Workbench software term for Online Editing is Run Mode Change (RMC).

1. While monitoring the ladder program, click the Run Mode Change icon. The ladder program will change to appear as if 
it is offline, even though the software is still online (‘Connected’).

2. Make your desired changes to the logic and/or tags, then test edits by clicking the Test Changes icon to the immediate 
right of Run Mode Change.
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3. To assemble the online edits to make the change permanent, click the Accept Changes icon to the right of the  
Test Changes icon.

4. To cancel the online edits to undo the changes, click the Discard Changes icon to the far right of Run Mode Change.

z
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Going Offline from a Controller

1. Double-click the Micro800 controller icon under Project Organizer to bring up the Micro800 window. Click the 
Disconnect button on the upper right-hand corner of the screen to go offline.
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Saving an Offline Project

A Connected Components Workbench software CCWARC archive file is equivalent to a Logix ACD file in that the one file 
encapsulates the entire Connected Components Workbench software project. However, you must export the project to save it in 
this file format.

1. Select File->Export Project…, browse to the desired directory and enter a file name (which will be given a .ccwarc 
extension) to save (‘archive’) the project to.
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Generating a Project Printout

1. Select Device->Document Generator (print). The only options are what is shown on this screen.
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Changing the Offline File Controller Catalog Number and/or Version

You can upgrade the controller project version for the existing controller catalog number to match the installed version of 
Connected Components Workbench software. Alternatively, you can change to another controller catalog number at the same 
controller project version as the installed version of Connected Components Workbench software. Unlike Logix, the controller 
firmware version does not need to match the controller project version, but it does have to be greater than or equal to it.

1. Open Connected Components Workbench software (under All Programs/Rockwell Automation/CCW).

2. Open an existing project.

3. Right click the Micro800 controller icon under Project Organizer and select Change Controller…
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4. Enter another Target Project Name and/or Controller Name from the defaults offered. Select your preferred Controller 
Type (catalog number) and click OK.
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Creating a New Controller Project

 Select the Controller Catalog Number and Version

1. Open Connected Components Workbench software (under All Programs/Rockwell Automation/CCW).

2. Click New… on the Start Page.

3. Enter your desired project name or accept the default name and click Create.
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4. Select the catalog number for your controller, choose the desired project Version (typically the latest, but does not have 
to be. The latest software also supports all earlier versions of projects, and the latest controller firmware also supports all 
earlier versions of projects), click Select and click Add To Project.
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 Configure the Communication Parameters

1. On the Micro800 controller page, click Ethernet and/or Serial Port to configure the desired communication settings.
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 Add and Configure Any Plug-in and/or Expansion Modules

1. Right-click the blank plug-in or expansion module slot on the controller graphic and select the module to add.

2. Alternatively, from the menu you can right-click either an < Empty > slot under Plug-in Modules or an < Available > slot 
under Expansion Modules (Micro850 or Micro870 controller) and select the module to add.
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3. Once you have added the module, the module configuration selections will appear.
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 Verify Rung Settings for Optimal Viewing

1. Under Tools\Options, verify that the Ladder Diagram Rung Settings for Coil Alignment is set to False and for Fit to 
Window Width is set to True.
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 Add a New Ladder Program

1. Under Project Organizer, right-click Programs and select Add->New LD: Ladder Diagram.
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 Open a Ladder Program

1. Double-click the ladder program name, such as default name Prog1 (which can be renamed), and the ladder program will 
open up with one blank rung.
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 Select Logix Theme and View Instruction Mapping

1. Use the Theme dropdown box to change the theme from Default to Logix. This theme will use Logix names and symbols 
for all ladder instructions that have the same functionality as Logix instructions.

2. An instruction mapping table of Default Names to Logix Theme Names can be found under Tools->Options->Theme-> 
Instruction Mapping.
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 Add a Ladder Instruction on a Rung

1. From the Instruction Library directly above the ladder rung, click and drag a ladder instruction (like Direct Contact in 
the Favorites group) down to the rung until a ‘+’ appears where the instruction is to be placed, then release the mouse 
button.
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 Assign a Tag to a Ladder Instruction

The Connected Components Workbench software term for Tag is Variable.

1. After placing the instruction, the Variable Selector window opens to allow you to select an existing tag (‘variable’) or 
to create a new one. The System Variables – Micro800 and I/O – Micro800 tabs contain the default system and I/O 
controller tags. The Local Variables - <program name> tab contains user-created tags that are scoped to this program. 
The User Global Variables – Micro800 tab contains user-created tags that are controller scoped. 

To select an existing tag, click the appropriate tab, click the desired tag and click OK. 

To create a tag, click either the User Global Variables or Local Variables tab to select whether the new tag will be 
globally scoped or locally scoped. 

Enter in the new tag name in the Name box and click OK.

TIP: Ctrl+R can be used to toggle off the automatic prompting 
from the Variable Selector which is more similar to Studio 5000.  
The bottom status bar will indicate either “Manual-Input Enable” or 
“Auto-Input Enable”.  Manual input of the tag name is useful when it 
is desired to enter just the instructions first and assigning tags later.
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 Add an Instruction Block on a Rung and Assign Its Input and Output Parameters

1. Select the program group in the Instruction Library that contains the instruction name you want. Click and drag the 
instruction down to the rung until a ‘+’ appears where the instruction is to be placed, then release the mouse button. 

Alternatively, you can double-click the name of the instruction in the Instruction Library to place it on the rung after 
the last instruction. If you don’t know which program group to find the instruction in, use the Search box to find the 
instruction.
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2. Hovering the mouse cursor over the instruction will identify the data types of the input and output parameters.  
For Arc Tangent, both parameters must be of data type REAL.

3. Double-click the lower half of the input parameter box to bring up the Variable Selector screen. From here, you can 
select an existing REAL tag (‘variable’) or create one and click OK.
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4. Similarly, double-click the lower half of the output parameter box to bring up the Variable Selector screen. From here, 
you can select an existing REAL tag (‘variable’) or create one and click OK.
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 Add a Rung and Ladder Instructions Using LD Text Input

1. Click the LD Text Input toggle to expand the LD Text Input window. The instruction text for rung 1 is displayed.

2. Place your cursor at the end of the rung 1 text and press Enter to create rung 2.
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3. In the blank text box next to 2, type in:  ”BST XIC _IO_EM_DI_00 TON TON_1 NXB XIC _IO_EM_DO_06 BND XIO _IO_EM_
DI_01 OTE _IO_EM_DO_06” to program rung 2.

BST – Branch Start
XIC – Examine If Closed (Direct Contact)
TON – On-delay Timer
NXB – Next Branch
BND – Branch End
OTE – Output Energize (Direct Coil)

TIP: To make it easier to enter the correct syntax for a branch, auto-completion 
is available if TAB key is pressed after typing “BST”.  Auto-completion for a 
branch will insert a “BST  NXB  BND“
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 Copy and Paste a Ladder Rung from Studio 5000

1. Right-click the desired rung within Studio 5000 and select Copy Rung.

2. With the LD Text Input window expanded (see toggle where the arrow below is pointing to), right-click within the box to 
the right of ‘1’ and click Paste.

TIP: Logix instructions such as NOP, SBR, INT, 
JSR and AFI are not supported in V11 Feature 
Pack. These instructions will appear as undeclared 
variables and assigned as input or output of 
an instruction. For more information, refer to 
Knowledgebase: 1074704 “Modify I/O tags to 
match Micro800 format and create any missing 
tags”.
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TIP: Multiple rungs of ladder logic can be pasted by 
selecting more than one rung before copying.  

TIP: ASCII text input will allow multiple output coils 
in series to be entered which cannot be entered 
using the graphical editor. Although Studio 5000 
supports this, Micro800 currently does not, and the 
output of the coil will always be TRUE.

 Continued from Copy and Paste a Ladder Rung from Studio 5000
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 Password Protect Program, If Desired

To prevent unauthorized viewing and editing of the program, both offline and online, you can assign a password to it. Passwords 
must contain 1 to 8 alphanumeric characters – no spaces or special characters are allowed. Assigning, changing and clearing 
program passwords require Connected Components Workbench Developer Edition software.

1. Right-click the program name and select Password.
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2. Enter New Password, reenter the password in Confirm Password and click OK.

3. In the future, any time the program is opened, whether offline or online, you will be prompted to enter the Password. 
After entering password, click OK to proceed.
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 Verify Controller Before Downloading

The Connected Components Workbench software term for Verify Controller is Build.

1. Click the Build icon to verify the controller project. Build success or failure is displayed in the Output window at the 
bottom of the screen. Only a project that has been successfully built can be downloaded to a controller.

2. If the build fails, review the error list to determine what needs to be corrected, attempt to fix it and then rebuild again. 
Repeat this process until the build succeeds.
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Importing an Add-On Instruction (AOI) or Subroutine to a Project

The Connected Components Workbench software term for an AOI is UDFB and for a subroutine is UDF.

1. Right-click the Micro800 controller icon under Project Organizer and select Import -> Import Exchange File.
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2. Click Browse, browse to and select the desired UDFB file, then click Import.

3. Imported AOIs and subroutines will be listed in the Project Organizer under User-Defined Function Blocks for AOIs and 
User-Defined Functions for subroutines.
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Using an AOI or Subroutine in a Program

The Connected Components Workbench software term for an AOI is UDFB and for a subroutine is UDF.

1. Once an AOI or subroutine is imported into a project, its name is listed in the (User defined) group. Select the  
(User defined) group, click the AOI or subroutine name and then drag and drop the AOI or subroutine onto the rung. 
There is no separate Jump to Subroutine (JSR) instruction needed for UDFs.
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2. Assign tags (‘variables’) to the instruction input and output parameters.
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Exporting and Importing Tags

The Connected Components Workbench software terms for Controller Tags are Global Variables, while Local Tags are called Local 
Variables.

1. Export Controller Tags by right-clicking the Micro800 controller icon under Project Organizer, selecting Export, then 
Variables. Browse to the desired directory and enter in a file name to save it under (in Microsoft Excel format) and click 
Save.
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2. Export Local Tags by right-clicking the desired Program’s icon under Project Organizer, selecting Export, then Variables. 
Browse to the desired directory and enter in a file name to save it under (in Microsoft Excel format) and click Save.
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3. Import Controller Tags by right-clicking the Micro800 controller icon under Project Organizer, selecting Import, then 
Variables. Browse to the desired directory and file name (in Microsoft Excel format) and click Open.
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4. Import Local Tags by right-clicking the desired Program’s icon under Project Organizer, selecting Import, then Variables. 
Browse to the desired directory and file (in Microsoft Excel format) and click Open.
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Keyboard Toggle Bit Shortcut

1. While online with the controller and with a bit instruction selected (as indicated by the bright green box surrounding 
the instruction), use Ctrl+T to toggle the instruction bit between off and on (as well as through the Toggle Boolean 
Value menu selection).
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Cross Referencing Tags

1. Select View->Cross Reference Browser to find where tags (‘variables’) are being used. Click (x unused Variables) to bring 
up the Unused Variable Browser, which includes a one-click Delete Unused Variables selection.



53. BACK

Renaming Tags

1. Existing tags (‘variables’) that are renamed are automatically updated everywhere the tag is assigned within the logic.
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Data Types

Connected Components Workbench supports more native data types than Studio 5000 for Integers and Reals and has differences 
when it comes to the BOOLean data type.

1. Connected Components Workbench supports unsigned integers (8-bit USINT/BYTE, 16-bit UINT/WORD, 32-bit UDINT/
DWORD, 64-bit ULINT/LWORD).

2. Connected Components Workbench supports 64-bit double precision real (LREAL).

3. Connected Components Workbench BOOLean occupies one byte of data.  Studio 5000 BOOLean occupies four bytes of 
data, or can also be part of an integer as a single bit.



For more information on software specifications and supported products, visit 

rockwellautomation.com/global/go/ccw

Appendix A – Additional Micro800 Controller Instruction Set Resources

1. Micro800 Programmable Controllers General Instructions Reference Manual 

(http://literature.rockwellautomation.com/idc/groups/literature/documents/rm/2080-rm001_-en-e.pdf)

2. MicroLogix™ 1000 Controllers to Micro800 Controllers Migration Guide

(http://literature.rockwellautomation.com/idc/groups/literature/documents/rm/2080-rm002_-en-e.pdf)

Publication 9328-QR001B-EN-E – August 2018 Copyright ©2018 Rockwell Automation, Inc. All Rights Reserved. 
Supersedes Publication 9328-QR001A-EN-E – August 2017

Allen-Bradley, Connected Components Workbench, LISTEN. THINK. SOLVE., Micro800, Micro810, Micro820, Micro830, Micro850, Micro870, MicroLogix, Rockwell Automation, Rockwell Software,  
Studio 5000 Logix Designer are trademarks of Rockwell Automation. Trademarks not belonging to Rockwell Automation are property of their respective companies.

http://rockwellautomation.com/global/go/ccw
http://literature.rockwellautomation.com/idc/groups/literature/documents/rm/2080-rm001_-en-e.pdf
http://literature.rockwellautomation.com/idc/groups/literature/documents/rm/2080-rm002_-en-e.pdf
http://www.rockwellautomation.com
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